[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / palomino

Annotation of ports/games/palomino/Makefile, Revision 1.1.1.1

1.1       yason       1: # $OpenBSD$
                      2: #ONLY_FOR_ARCHS =      ???
                      3: #NOT_FOR_ARCHS =       ???
                      4: #SHARED_ONLY =         ???
                      5: #COMES_WITH =          ???
                      6: #BROKEN =              reason
                      7:
                      8: COMMENT =              ???
                      9: # COMMENT-foo =                ???     for multi packages
                     10:
                     11: DISTNAME =             palomino_src_20090615
                     12: #PKGNAME =             ???
                     13: #PKGNAME-foo =         ???     for multi packages
                     14:
                     15: #SHARED_LIBS =         ???
                     16:
                     17: CATEGORIES =           games
                     18:
                     19: #HOMEPAGE =            ???     URL
                     20:
                     21: #MAINTAINER =          ???
                     22:
                     23: # GPLv2
                     24: PERMIT_PACKAGE_CDROM = Yes
                     25: PERMIT_PACKAGE_FTP =   Yes
                     26: PERMIT_DISTFILES_CDROM =Yes
                     27: PERMIT_DISTFILES_FTP = Yes
                     28:
                     29: #WANTLIB =             ???
                     30:
                     31: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=palomino-sim/}
                     32: #DISTFILES =           ???
                     33: #EXTRACT_ONLY =                ???
                     34: EXTRACT_SUFX =         .tar.bz2
                     35:
                     36: #DIST_SUBDIR =         ???
                     37:
                     38: MODULES =              devel/cmake
                     39: #BUILD_DEPENDS =       ???
                     40: #RUN_DEPENDS =         ???
                     41: LIB_DEPENDS =          graphics/osg
                     42: #REGRESS_DEPENDS =     ???
                     43:
                     44: #MAKE_FLAGS =          ???
                     45: #MAKE_ENV =            ???
                     46: #FAKE_FLAGS =          ???
                     47: #REGRESS_FLAGS =       ???
                     48:
                     49: # build/configuration variables
                     50: #
                     51: #SEPARATE_BUILD =      concurrent  (build simultaneously on all arches)
                     52: #SEPARATE_BUILD =      simple  (configure/build still recreates files in source)
                     53: #USE_X11 =             Yes
                     54: #USE_GMAKE =           Yes
                     55: # Programs that uses libtool should use this option,
                     56: # unless there is a really good reason not to.
                     57: #USE_LIBTOOL =         Yes
                     58: # Set CONFIGURE_STYLE to value corresponding to some standard configuration
                     59: #        perl [modbuild]: perl's MakeMaker Makefile.PL (modbuild: perl's
                     60: #        Module::Build Build.PL)
                     61: #        gnu [autoconf] [old] [dest]: gnu style configure (old: no
                     62: #        sysconfdir), (dest: add DESTDIR, does not handle it),
                     63: #        (autoconf: needed by port, implies gnu)
                     64: #      XXX: cygnus products do NOT use autoconf for making the main
                     65: #              configure from configure.in
                     66: #        imake [noman]: port uses imake for configuration.
                     67: #        (noman: no man page installation)
                     68: #        simple: port has its own configure script
                     69: #CONFIGURE_STYLE =
                     70: #CONFIGURE_SCRIPT =    ??? (if other than configure)
                     71: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
                     72: #CONFIGURE_ENV =       ???
                     73:
                     74: #FLAVORS =     1 2 3 a b
                     75: #FLAVOR ?=
                     76: # grab multiple choice value
                     77: #CHOICE = ${FLAVOR:L:Na:Nb}
                     78: # check that CHOICE is 1 OR 2 OR 3, or error out
                     79: #.if ${CHOICE} == "1"
                     80: # code for 1
                     81: #.elif ${CHOICE} == "2"
                     82: # code for 2
                     83: #.elif ${CHOICE} == "3"
                     84: # code for 3
                     85: #.else
                     86: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
                     87: #.endif
                     88: # check for switches
                     89: #.if ${FLAVOR:L:Ma}
                     90: # code for a
                     91: #.endif
                     92: #.if ${FLAVOR:L:Mb}
                     93: # code for b
                     94: #.endif
                     95:
                     96: #NO_REGRESS =          Yes
                     97:
                     98: #CFLAGS =              ???
                     99: #LDFLAGS =             ???
                    100: #MAKE_FILE =           ???
                    101: #PKG_ARCH =            ???
                    102: WRKDIST =              ${WRKDIR}/palomino
                    103: #WRKSRC =              ??? if other than ${WRKDIST}
                    104: #WRKBUILD =            ??? if other than ${WRKSRC}
                    105: #WRKCONF =             ??? if other than ${WRKBUILD}
                    106:
                    107: #ALL_TARGET =          ???
                    108: #INSTALL_TARGET =      ???
                    109: #REGRESS_TARGET =      ???
                    110:
                    111: .include <bsd.port.mk>

CVSweb