[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / sk1project / libs

Annotation of ports/graphics/sk1project/libs/Makefile, Revision 1.1

1.1     ! yason       1: # $OpenBSD$
        !             2:
        !             3: COMMENT =              sK1 libs
        !             4:
        !             5: DISTNAME =             sk1libs-0.9.1pre_rev1014
        !             6:
        !             7: WANTLIB =              freetype z
        !             8:
        !             9: MASTER_SITES =         ${HOMEPAGE}/downloads/sk1/${V}/
        !            10:
        !            11: MODULES =              lang/python
        !            12:
        !            13: #XXX lcms shoul be compiled --with-python
        !            14: LIB_DEPENDS =          jpeg::graphics/jpeg \
        !            15:                        lcms.>=2::graphics/lcms \
        !            16:
        !            17: MAKE_ENV =             CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -I${X11BASE}/include/freetype2" \
        !            18:                        LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
        !            19:
        !            20: NO_REGRESS =           Yes
        !            21:
        !            22: do-configure:
        !            23: #      perl -pi -e 's,/usr/bin/python,${MODPY_BIN},g' ${WRKSRC}/src/__init__.py
        !            24:        perl -pi -e 's,python,${MODPY_BIN},g' ${WRKSRC}/setup.py
        !            25:
        !            26: .include <bsd.port.mk>

CVSweb