[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / sk1project / libs

File: [local] / ports / graphics / sk1project / libs / Attic / Makefile (download)

Revision 1.1.1.1 (vendor branch), Fri Apr 16 08:01:44 2010 UTC (14 years, 2 months ago) by yason
Branch: yason
CVS Tags: import
Changes since 1.1: +0 -0 lines

import

# $OpenBSD$

COMMENT =		sK1 libs

DISTNAME =		sk1libs-0.9.1pre_rev1014

WANTLIB =		freetype z

MASTER_SITES =		${HOMEPAGE}/downloads/sk1/${V}/

MODULES =		lang/python

#XXX lcms shoul be compiled --with-python
LIB_DEPENDS =		jpeg::graphics/jpeg \
			lcms.>=2::graphics/lcms \

MAKE_ENV =		CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -I${X11BASE}/include/freetype2" \
			LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"

NO_REGRESS =		Yes

do-configure:
#	perl -pi -e 's,/usr/bin/python,${MODPY_BIN},g' ${WRKSRC}/src/__init__.py
	perl -pi -e 's,python,${MODPY_BIN},g' ${WRKSRC}/setup.py

.include <bsd.port.mk>